Antwort: [DB2-L] DB2 v8 z/os - Possible data corruption?

Roy Boxwell

Antwort: [DB2-L] DB2 v8 z/os - Possible data corruption?
Hi!

Like the other replies it could be caused by "residual" bad data caused
by using one of the non-IBM reorgs at anytime in the past on this table.
There is an APAR which describes
the repair you must run on the DBD to clean up the "corrupted" bytes. The
other possibility is if this object had a DBID of 1 (I think) there was a
known issue that reorg would treat
this tablespace "differently" in V8. Again there is an APAR that describes
it and the fix is what you basically did! (Drop and recreate the TS)

Roy Boxwell
SOFTWARE ENGINEERING GMBH
-Product Development-
Robert-Stolz-Strasse 5
40470 Duesseldorf/Germany
Tel. +49 (0)211 96149-0
Fax +49 (0)211 96149-35
E-mail [login to unmask email]
Homepage www.seg.de





"Hodgin, Scott" <[login to unmask email]>
Gesendet von: DB2 Data Base Discussion List <[login to unmask email]>
15.12.2005 00:49
Bitte antworten an DB2 Database Discussion list at IDUG


An: [login to unmask email]
Kopie:
Thema: [DB2-L] DB2 v8 z/os - Possible data corruption?


Hi list,

I have not opened an issue with IBM on this yet, but I was wondering if
anyone could shed some light on a problem we encountered after upgrading
our prod systems to v8 this passed weekend.

As far as I know, everything has been fine on a given table containing
about 711,000 rows as of Saturday morning full backup.

On Monday night, we had a load resume yes run and issued RC4 saying resume
yes was specified for an empty tablespace (no one noticed this rc4).
Tuesday night, a delete blew up with some 'inconsistancy' errors.
I recovered the tablespace to Saturday morning's fullcopy and rebuilt the
indexes
Select count indicated a reasonable row total
I tried reorging the table - 0 rows unloaded and 0 rows loaded.

I again recovered the table to Saturday mornings backup.
Ran dsntiaul which unloaded the correct number of rows
Ran load replace on table with the dsntiaul input
The correct number of rows were loaded
Ran reorg - 0 rows unloaded and 0 rows loaded


i completely dropped the entire tablespace and recreated it along with the
1 table and indexes and authorities.
Ran load replace with the previous dsntiaul unloaded rows from above
Ran reorg and everything was fine.




This seems to be the only table in this situation (so far)


Can anyone explain what could have happened?

Scott Hodgin, Database Administrator
South Carolina Farm Bureau Insurance Company
[login to unmask email]

---------------------------------------------------------------------------------
Welcome to the IDUG DB2-L list. To unsubscribe, go to the archives and
home page at http://www.idugdb2-l.org/archives/db2-l.html. From that page select "Join or Leave the list". The IDUG DB2-L FAQ is at
http://www.idugdb2-l.org. The IDUG List Admins can be reached at [login to unmask email]
Find out the latest on IDUG conferences at http://conferences.idug.org/index.cfm


---------------------------------------------------------------------------------
Welcome to the IDUG DB2-L list. To unsubscribe, go to the archives and home page at http://www.idugdb2-l.org/archives/db2-l.html. From that page select "Join or Leave the list". The IDUG DB2-L FAQ is at http://www.idugdb2-l.org. The IDUG List Admins can be reached at [login to unmask email] Find out the latest on IDUG conferences at http://conferences.idug.org/index.cfm