Java Drivers backward compatibility (Websphere to DB2 z/OS V10)

Philip Sevetson

Java Drivers backward compatibility (Websphere to DB2 z/OS V10)
**please note my email address change**
Can anyone point me to the page (or a search argument which will get me to the page) for Websphere (DB2-Connect?) DB2 drivers?

We're upgrading to V11, and I'm trying to establish whether any of the currently available drivers are so advanced that they _won't_ talk to DB2 z/OS V10. Our Websphere people want to modernize their drivers as far as possible (Currently using Type 3's on V10fp3 in production; Type 4's on V10fp8 in test).

If we update to the most recent DB2 Driver release, will we still be able to call DB2 z/OS V10 subsystems?

Philip Sevetson
Computer Systems Manager
5 Manhattan West (33rd St at 10th Ave)
New York, NY 10001-2632
212-857-1688 w
917-991-7052 c
212-857-1659 f
[cid:[login to unmask email]

**This e-mail, including any attachments, may be confidential, privileged, or otherwise legally protected. It is intended only for the addressee. If you received this e-mail in error or from someone who was not authorized to send it to you, do not disseminate, copy, or otherwise use this e-mail or its attachments. Please notify the sender immediately by reply e-mail and delete the e-mail from your system.**
Attachments

  • image001.png (3.3k)

Philip Sevetson

Java Drivers backward compatibility (Websphere to DB2 z/OS V10)
(in response to Philip Sevetson)
**please note my email address change**
Whoops. Java Drivers are currently using V10.5 fixpacks, not V10. Sorry for the error.

Philip Sevetson
Computer Systems Manager
5 Manhattan West (33rd St at 10th Ave)
New York, NY 10001-2632
212-857-1688 w
917-991-7052 c
212-857-1659 f
[cid:[login to unmask email]

From: Sevetson, Phil [mailto:[login to unmask email]
Sent: Thursday, May 04, 2017 12:45 PM
To: [login to unmask email]
Subject: [DB2-L] - Java Drivers backward compatibility (Websphere to DB2 z/OS V10)

**please note my email address change**
Can anyone point me to the page (or a search argument which will get me to the page) for Websphere (DB2-Connect?) DB2 drivers?

We're upgrading to V11, and I'm trying to establish whether any of the currently available drivers are so advanced that they _won't_ talk to DB2 z/OS V10. Our Websphere people want to modernize their drivers as far as possible (Currently using Type 3's on V10fp3 in production; Type 4's on V10fp8 in test).

If we update to the most recent DB2 Driver release, will we still be able to call DB2 z/OS V10 subsystems?

Philip Sevetson
Computer Systems Manager
5 Manhattan West (33rd St at 10th Ave)
New York, NY 10001-2632
212-857-1688 w
917-991-7052 c
212-857-1659 f
[cid:[login to unmask email]

**This e-mail, including any attachments, may be confidential, privileged, or otherwise legally protected. It is intended only for the addressee. If you received this e-mail in error or from someone who was not authorized to send it to you, do not disseminate, copy, or otherwise use this e-mail or its attachments. Please notify the sender immediately by reply e-mail and delete the e-mail from your system.**
-----End Original Message-----
**This e-mail, including any attachments, may be confidential, privileged, or otherwise legally protected. It is intended only for the addressee. If you received this e-mail in error or from someone who was not authorized to send it to you, do not disseminate, copy, or otherwise use this e-mail or its attachments. Please notify the sender immediately by reply e-mail and delete the e-mail from your system.**
Attachments

  • image001.png (3.3k)

Kenneth Lee

Java Drivers backward compatibility (Websphere to DB2 z/OS V10)
(in response to Philip Sevetson)
Phil,
For Type 4, download the latest DB2 JDBC Driver version for JDBC and SQLJ from here and yes, it still be able to talk to DB2 z/OS v10.

http://www-01.ibm.com/support/docview.wss?rs=71&uid=swg21363866

Ken

From: Sevetson, Phil [mailto:[login to unmask email]
Sent: Thursday, May 04, 2017 12:49 PM
To: '[login to unmask email]'
Subject: [DB2-L] - RE: Java Drivers backward compatibility (Websphere to DB2 z/OS V10)

**please note my email address change**
Whoops. Java Drivers are currently using V10.5 fixpacks, not V10. Sorry for the error.

Philip Sevetson
Computer Systems Manager
5 Manhattan West (33rd St at 10th Ave)
New York, NY 10001-2632
212-857-1688 w
917-991-7052 c
212-857-1659 f
[cid:[login to unmask email]

From: Sevetson, Phil [mailto:[login to unmask email]
Sent: Thursday, May 04, 2017 12:45 PM
To: [login to unmask email]<mailto:[login to unmask email]>
Subject: [DB2-L] - Java Drivers backward compatibility (Websphere to DB2 z/OS V10)

**please note my email address change**
Can anyone point me to the page (or a search argument which will get me to the page) for Websphere (DB2-Connect?) DB2 drivers?

We're upgrading to V11, and I'm trying to establish whether any of the currently available drivers are so advanced that they _won't_ talk to DB2 z/OS V10. Our Websphere people want to modernize their drivers as far as possible (Currently using Type 3's on V10fp3 in production; Type 4's on V10fp8 in test).

If we update to the most recent DB2 Driver release, will we still be able to call DB2 z/OS V10 subsystems?

Philip Sevetson
Computer Systems Manager
5 Manhattan West (33rd St at 10th Ave)
New York, NY 10001-2632
212-857-1688 w
917-991-7052 c
212-857-1659 f
[cid:[login to unmask email]

**This e-mail, including any attachments, may be confidential, privileged, or otherwise legally protected. It is intended only for the addressee. If you received this e-mail in error or from someone who was not authorized to send it to you, do not disseminate, copy, or otherwise use this e-mail or its attachments. Please notify the sender immediately by reply e-mail and delete the e-mail from your system.**
-----End Original Message-----
**This e-mail, including any attachments, may be confidential, privileged, or otherwise legally protected. It is intended only for the addressee. If you received this e-mail in error or from someone who was not authorized to send it to you, do not disseminate, copy, or otherwise use this e-mail or its attachments. Please notify the sender immediately by reply e-mail and delete the e-mail from your system.**
-----End Original Message-----

This message is confidential and subject to terms at: http://www.jpmorgan.com/emaildisclaimer including on confidentiality, legal privilege, viruses and monitoring of electronic messages. If you are not the intended recipient, please delete this message and notify the sender immediately. Any unauthorized use is strictly prohibited.

Philip Sevetson

Java Drivers backward compatibility (Websphere to DB2 z/OS V10)
(in response to Kenneth Lee)
**please note my email address change**
Thank you :-)

Philip Sevetson
Computer Systems Manager
5 Manhattan West (33rd St at 10th Ave)
New York, NY 10001-2632
212-857-1688 w
917-991-7052 c
212-857-1659 f
[cid:[login to unmask email]

From: Lee, Kenneth [mailto:[login to unmask email]
Sent: Thursday, May 04, 2017 2:59 PM
To: '[login to unmask email]'
Subject: [DB2-L] - RE: Java Drivers backward compatibility (Websphere to DB2 z/OS V10)

Phil,
For Type 4, download the latest DB2 JDBC Driver version for JDBC and SQLJ from here and yes, it still be able to talk to DB2 z/OS v10.

http://www-01.ibm.com/support/docview.wss?rs=71&uid=swg21363866

Ken


From: Sevetson, Phil [mailto:[login to unmask email]
Sent: Thursday, May 04, 2017 12:49 PM
To: '[login to unmask email]'
Subject: [DB2-L] - RE: Java Drivers backward compatibility (Websphere to DB2 z/OS V10)

**please note my email address change**
Whoops. Java Drivers are currently using V10.5 fixpacks, not V10. Sorry for the error.

Philip Sevetson
Computer Systems Manager
5 Manhattan West (33rd St at 10th Ave)
New York, NY 10001-2632
212-857-1688 w
917-991-7052 c
212-857-1659 f
[cid:[login to unmask email]

From: Sevetson, Phil [mailto:[login to unmask email]
Sent: Thursday, May 04, 2017 12:45 PM
To: [login to unmask email]<mailto:[login to unmask email]>
Subject: [DB2-L] - Java Drivers backward compatibility (Websphere to DB2 z/OS V10)

**please note my email address change**
Can anyone point me to the page (or a search argument which will get me to the page) for Websphere (DB2-Connect?) DB2 drivers?

We're upgrading to V11, and I'm trying to establish whether any of the currently available drivers are so advanced that they _won't_ talk to DB2 z/OS V10. Our Websphere people want to modernize their drivers as far as possible (Currently using Type 3's on V10fp3 in production; Type 4's on V10fp8 in test).

If we update to the most recent DB2 Driver release, will we still be able to call DB2 z/OS V10 subsystems?

Philip Sevetson
Computer Systems Manager
5 Manhattan West (33rd St at 10th Ave)
New York, NY 10001-2632
212-857-1688 w
917-991-7052 c
212-857-1659 f
[cid:[login to unmask email]

**This e-mail, including any attachments, may be confidential, privileged, or otherwise legally protected. It is intended only for the addressee. If you received this e-mail in error or from someone who was not authorized to send it to you, do not disseminate, copy, or otherwise use this e-mail or its attachments. Please notify the sender immediately by reply e-mail and delete the e-mail from your system.**
-----End Original Message-----
**This e-mail, including any attachments, may be confidential, privileged, or otherwise legally protected. It is intended only for the addressee. If you received this e-mail in error or from someone who was not authorized to send it to you, do not disseminate, copy, or otherwise use this e-mail or its attachments. Please notify the sender immediately by reply e-mail and delete the e-mail from your system.**
-----End Original Message-----

This message is confidential and subject to terms at: http://www.jpmorgan.com/emaildisclaimer http://www.jpmorgan.com/emaildisclaimer including on confidentiality, legal privilege, viruses and monitoring of electronic messages. If you are not the intended recipient, please delete this message and notify the sender immediately. Any unauthorized use is strictly prohibited.

-----End Original Message-----
**This e-mail, including any attachments, may be confidential, privileged, or otherwise legally protected. It is intended only for the addressee. If you received this e-mail in error or from someone who was not authorized to send it to you, do not disseminate, copy, or otherwise use this e-mail or its attachments. Please notify the sender immediately by reply e-mail and delete the e-mail from your system.**
Attachments

  • image001.png (3.3k)

Douwe van Sluis

Java Drivers backward compatibility (Websphere to DB2 z/OS V10)
(in response to Philip Sevetson)
Hi Philip,

If you are talking about the DB2 Universal JDBC Driver files, these are
downwards compatible.
It is usually a good idea to get the latest files from your DB2 z/OS USS
directory. One can easily download them to other places.
The db2jcc4.jar contains the JDBC 4.0 standard, which is advised to be used
for support of the latest jdbc standards.

It occurred to me once that I had to download/use the latest version, I
think it was at version 9, to see the Database structure when using SQL
Explorer.

Have fun and good luck with the DB2 for z/OS Driver (files). It's great and
easy to use.

Make sure you have the proper DB2 Connect license if you copy and use
the db2jcc_license_cisuz.jar !!
Btw this file is release independent.

Let me know if you need more help.

Vriendelijke groet,
*Douwe van Sluis*


2017-05-04 18:45 GMT+02:00 Sevetson, Phil <[login to unmask email]>:

> **please note my email address change**
>
> Can anyone point me to the page (or a search argument which will get me to
> the page) for Websphere (DB2-Connect?) DB2 drivers?
>
>
>
> We’re upgrading to V11, and I’m trying to establish whether any of the
> currently available drivers are so advanced that they _*won’t*_ talk to
> DB2 z/OS V10. Our Websphere people want to modernize their drivers as far
> as possible (Currently using Type 3’s on V10fp3 in production; Type 4’s on
> V10fp8 in test).
>
>
>
> If we update to the most recent DB2 Driver release, will we still be able
> to call DB2 z/OS V10 subsystems?
>
>
>
> Philip Sevetson
>
> Computer Systems Manager
>
> 5 Manhattan West (33rd St at 10th Ave)
>
> New York, NY 10001-2632
>
> 212-857-1688 <(212)%20857-1688> w
>
> 917-991-7052 <(917)%20991-7052> c
>
> 212-857-1659 <(212)%20857-1659> f
>
> [image: cid:[login to unmask email]
>
>
> **This e-mail, including any attachments, may be confidential, privileged,
> or otherwise legally protected. It is intended only for the addressee. If
> you received this e-mail in error or from someone who was not authorized to
> send it to you, do not disseminate, copy, or otherwise use this e-mail or
> its attachments. Please notify the sender immediately by reply e-mail and
> delete the e-mail from your system.**
> -----End Original Message-----
>

Charles Brown

Java Drivers backward compatibility (Websphere to DB2 z/OS V10)
(in response to Douwe van Sluis)

Re: ...they _won’t_ talk to DB2 z/OS V10.

If it's an IBM software, you've guessed it all drivers; all APARs; all fixpacks; all PTFs; all new releases -- are downward compatible. IBM program changes are cumulative. Meaning - new programs or fixes contain previous programs or previous fixes.

To answer your question -- db2 connect drivers are downward compatible

Hope this helps
Sent from my iPhone

> On May 8, 2017, at 1:44 PM, Douwe van Sluis <[login to unmask email]> wrote:
>
> Hi Philip,
>
> If you are talking about the DB2 Universal JDBC Driver files, these are downwards compatible.
> It is usually a good idea to get the latest files from your DB2 z/OS USS directory. One can easily download them to other places.
> The db2jcc4.jar contains the JDBC 4.0 standard, which is advised to be used for support of the latest jdbc standards.
>
> It occurred to me once that I had to download/use the latest version, I think it was at version 9, to see the Database structure when using SQL Explorer.
>
> Have fun and good luck with the DB2 for z/OS Driver (files). It's great and easy to use.
>
> Make sure you have the proper DB2 Connect license if you copy and use the db2jcc_license_cisuz.jar !!
> Btw this file is release independent.
> Let me know if you need more help.
>
> Vriendelijke groet,
> Douwe van Sluis
>
>
>
> 2017-05-04 18:45 GMT+02:00 Sevetson, Phil <[login to unmask email]>:
>> **please note my email address change**
>> Can anyone point me to the page (or a search argument which will get me to the page) for Websphere (DB2-Connect?) DB2 drivers?
>>
>>
>>
>> We’re upgrading to V11, and I’m trying to establish whether any of the currently available drivers are so advanced that they _won’t_ talk to DB2 z/OS V10. Our Websphere people want to modernize their drivers as far as possible (Currently using Type 3’s on V10fp3 in production; Type 4’s on V10fp8 in test).
>>
>>
>>
>> If we update to the most recent DB2 Driver release, will we still be able to call DB2 z/OS V10 subsystems?
>>
>>
>>
>> Philip Sevetson
>>
>> Computer Systems Manager
>>
>> 5 Manhattan West (33rd St at 10th Ave)
>>
>> New York, NY 10001-2632
>>
>> 212-857-1688 w
>>
>> 917-991-7052 c
>>
>> 212-857-1659 f
>>
>>
>>
>>
>>
>> **This e-mail, including any attachments, may be confidential, privileged, or otherwise legally protected. It is intended only for the addressee. If you received this e-mail in error or from someone who was not authorized to send it to you, do not disseminate, copy, or otherwise use this e-mail or its attachments. Please notify the sender immediately by reply e-mail and delete the e-mail from your system.**
>> Attachment Links: image001.png (3 k)
>> Site Links: View post online View mailing list online Start new thread via email Unsubscribe from this mailing list Manage your subscription
>>
>> This email has been sent to: [login to unmask email]
>> Learn how ESAi's fast data refresh & Test Data Management products can save up to 90% in CPU, I/O
>> and manual efforts compared to typical solutions. Be a hero to your users with BCV5 & XDM. See
>> http://www.ESAIGroup.com/idug
>>
>> Use of this email content is governed by the terms of service at:
>> http://www.idug.org/p/cm/ld/fid=2
>>
>
>
> Site Links: View post online View mailing list online Start new thread via email Unsubscribe from this mailing list Manage your subscription
>
> This email has been sent to: [login to unmask email]
> Learn how ESAi's fast data refresh & Test Data Management products can save up to 90% in CPU, I/O
> and manual efforts compared to typical solutions. Be a hero to your users with BCV5 & XDM. See
> http://www.ESAIGroup.com/idug
>
> Use of this email content is governed by the terms of service at:
> http://www.idug.org/p/cm/ld/fid=2
>

Ludovic Janssens

Java Drivers backward compatibility (Websphere to DB2 z/OS V10)
(in response to Philip Sevetson)
Hi Philip,

You can always download the latest (and previous) version(s) of the DB2 drivers in all flavors from Fix Central: https://www.ibm.com/support/fixcentral

Best regards,

Ludovic Janssens
Senior Consultant 


From: Douwe van Sluis <[login to unmask email]>
Reply-To: "[login to unmask email]" <[login to unmask email]>
Date: Monday, 8 May 2017 at 20:44
To: "[login to unmask email]" <[login to unmask email]>
Subject: [DB2-L] - RE: Java Drivers backward compatibility (Websphere to DB2 z/OS V10)
Resent-From: <[login to unmask email]>
Resent-Date: Monday, 8 May 2017 at 20:45

Hi Philip,

If you are talking about the DB2 Universal JDBC Driver files, these are downwards compatible.
It is usually a good idea to get the latest files from your DB2 z/OS USS directory. One can easily download them to other places.
The db2jcc4.jar contains the JDBC 4.0 standard, which is advised to be used for support of the latest jdbc standards.

It occurred to me once that I had to download/use the latest version, I think it was at version 9, to see the Database structure when using SQL Explorer.

Have fun and good luck with the DB2 for z/OS Driver (files). It's great and easy to use.

Make sure you have the proper DB2 Connect license if you copy and use the db2jcc_license_cisuz.jar !!
Btw this file is release independent.

Let me know if you need more help.

Vriendelijke groet,
Douwe van Sluis

2017-05-04 18:45 GMT+02:00 Sevetson, Phil <[login to unmask email]<mailto:[login to unmask email]>>:
**please note my email address change**
Can anyone point me to the page (or a search argument which will get me to the page) for Websphere (DB2-Connect?) DB2 drivers?

We’re upgrading to V11, and I’m trying to establish whether any of the currently available drivers are so advanced that they _won’t_ talk to DB2 z/OS V10. Our Websphere people want to modernize their drivers as far as possible (Currently using Type 3’s on V10fp3 in production; Type 4’s on V10fp8 in test).

If we update to the most recent DB2 Driver release, will we still be able to call DB2 z/OS V10 subsystems?

Philip Sevetson
Computer Systems Manager
5 Manhattan West (33rd St at 10th Ave)
New York, NY 10001-2632
212-857-1688<tel:(212)%20857-1688> w
917-991-7052<tel:(917)%20991-7052> c
212-857-1659<tel:(212)%20857-1659> f
Error! Filename not specified.

**This e-mail, including any attachments, may be confidential, privileged, or otherwise legally protected. It is intended only for the addressee. If you received this e-mail in error or from someone who was not authorized to send it to you, do not disseminate, copy, or otherwise use this e-mail or its attachments. Please notify the sender immediately by reply e-mail and delete the e-mail from your system.**
-----End Original Message-----


AE-Disclaimer:

Dit bericht is vertrouwelijk en exclusief bestemd voor de geadresseerde ervan. Behoudens andersluidende expliciete afspraak is publicatie, gebruik of verspreiding ervan niet toegelaten. Gelieve de afzender onmiddellijk te verwittigen in geval van foutieve adressering of ontvangst en verwijder het bericht. Visies en opinies uitgedrukt in dit bericht zijn persoonlijk van de afzender tenzij aangegeven als zijnde van AE of verbonden ondernemingen.

This communication is intended for the addressee only and is privileged and confidential. Any unauthorized disclosure, copying, distribution or use is prohibited. If you have received this communication in error, please notify the sender immediately and destroy the original communication. Views and opinions are those of the sender unless clearly stated as being those of AE NV, its subsidiaries and/or associated companies.

Philip Sevetson

Java Drivers backward compatibility (Websphere to DB2 z/OS V10)
(in response to Ludovic Janssens)
**please note my email address change**
Folks,

TYVM (Thank You Very Much) for this info. We’ve caught up and are in good shape – we and the Websphere admins are now aware of what we have to do to be correctly connected from WS to DB2 z/OS.

Philip Sevetson
Computer Systems Manager
5 Manhattan West (33rd St at 10th Ave)
New York, NY 10001-2632
212-857-1688 w
917-991-7052 c
212-857-1659 f
[cid:[login to unmask email]

From: Ludovic Janssens [mailto:[login to unmask email]
Sent: Tuesday, May 09, 2017 1:51 AM
To: [login to unmask email]
Subject: [DB2-L] - RE: Java Drivers backward compatibility (Websphere to DB2 z/OS V10)

Hi Philip,

You can always download the latest (and previous) version(s) of the DB2 drivers in all flavors from Fix Central: https://www.ibm.com/support/fixcentral

Best regards,

Ludovic Janssens
Senior Consultant 


From: Douwe van Sluis <[login to unmask email]<mailto:[login to unmask email]>>
Reply-To: "[login to unmask email]<mailto:[login to unmask email]>" <[login to unmask email]<mailto:[login to unmask email]>>
Date: Monday, 8 May 2017 at 20:44
To: "[login to unmask email]<mailto:[login to unmask email]>" <[login to unmask email]<mailto:[login to unmask email]>>
Subject: [DB2-L] - RE: Java Drivers backward compatibility (Websphere to DB2 z/OS V10)
Resent-From: <[login to unmask email]<mailto:[login to unmask email]>>
Resent-Date: Monday, 8 May 2017 at 20:45

Hi Philip,

If you are talking about the DB2 Universal JDBC Driver files, these are downwards compatible.
It is usually a good idea to get the latest files from your DB2 z/OS USS directory. One can easily download them to other places.
The db2jcc4.jar contains the JDBC 4.0 standard, which is advised to be used for support of the latest jdbc standards.

It occurred to me once that I had to download/use the latest version, I think it was at version 9, to see the Database structure when using SQL Explorer.

Have fun and good luck with the DB2 for z/OS Driver (files). It's great and easy to use.

Make sure you have the proper DB2 Connect license if you copy and use the db2jcc_license_cisuz.jar !!
Btw this file is release independent.

Let me know if you need more help.

Vriendelijke groet,
Douwe van Sluis

2017-05-04 18:45 GMT+02:00 Sevetson, Phil <[login to unmask email]<mailto:[login to unmask email]>>:
**please note my email address change**
Can anyone point me to the page (or a search argument which will get me to the page) for Websphere (DB2-Connect?) DB2 drivers?

We’re upgrading to V11, and I’m trying to establish whether any of the currently available drivers are so advanced that they _won’t_ talk to DB2 z/OS V10. Our Websphere people want to modernize their drivers as far as possible (Currently using Type 3’s on V10fp3 in production; Type 4’s on V10fp8 in test).

If we update to the most recent DB2 Driver release, will we still be able to call DB2 z/OS V10 subsystems?

Philip Sevetson
Computer Systems Manager
5 Manhattan West (33rd St at 10th Ave)
New York, NY 10001-2632
212-857-1688<tel:(212)%20857-1688> w
917-991-7052<tel:(917)%20991-7052> c
212-857-1659<tel:(212)%20857-1659> f
Error! Filename not specified.

**This e-mail, including any attachments, may be confidential, privileged, or otherwise legally protected. It is intended only for the addressee. If you received this e-mail in error or from someone who was not authorized to send it to you, do not disseminate, copy, or otherwise use this e-mail or its attachments. Please notify the sender immediately by reply e-mail and delete the e-mail from your system.**
-----End Original Message-----


AE-Disclaimer:

Dit bericht is vertrouwelijk en exclusief bestemd voor de geadresseerde ervan. Behoudens andersluidende expliciete afspraak is publicatie, gebruik of verspreiding ervan niet toegelaten. Gelieve de afzender onmiddellijk te verwittigen in geval van foutieve adressering of ontvangst en verwijder het bericht. Visies en opinies uitgedrukt in dit bericht zijn persoonlijk van de afzender tenzij aangegeven als zijnde van AE of verbonden ondernemingen.

This communication is intended for the addressee only and is privileged and confidential. Any unauthorized disclosure, copying, distribution or use is prohibited. If you have received this communication in error, please notify the sender immediately and destroy the original communication. Views and opinions are those of the sender unless clearly stated as being those of AE NV, its subsidiaries and/or associated companies.

-----End Original Message-----
**This e-mail, including any attachments, may be confidential, privileged, or otherwise legally protected. It is intended only for the addressee. If you received this e-mail in error or from someone who was not authorized to send it to you, do not disseminate, copy, or otherwise use this e-mail or its attachments. Please notify the sender immediately by reply e-mail and delete the e-mail from your system.**
Attachments

  • image001.png (3.3k)