When is Fast Load Neither?

Ed Long

When is Fast Load Neither?
Hi all. I was wondering whether anyone else has had a problem with
Ca/Platinum Fast Load similar to the following.

We have 2 DB2 systems on the same image, lets call them X and J.
X is non-Datasharing, J is in a 2way datasharing relationship. Both systems
are DB2 V5.1, quite up to date maintenance wise.

A Fast load job for a table with a single clustering index works fine on X
but fails on J. There is nothing special about the table, no RI for example.
The utility discards all records in the input dataset. Everything is the
same, input dataset, same JCL except for DB2 subsystem stuff, ie DSNLOAD.
The DISCARDS parameter is set to 0.

We used RC/MIGRATE to build the J tables from X. The IBM load has no trouble
loading the data into J, it just takes a while.

We have opened a ticket with Ca/P but we are now 24hours into the adventure
and there has been no response. Obviously, their level 1 guy didn't see
anything in his database of a similar nature.

As a work around, I have converted all 300 jobs to use IBM load for now.

Any suggestions, or similar events.

Thanks for your suggestions.



[login to unmask email]

Re: When is Fast Load Neither?
(in response to Ed Long)
Ed,
Is FASTLOAD using the OBID of the object it's loading into? Was the data
unloaded using FAST UNLOAD and with the load control parameter set to
FASTLOAD?

This would account for the entire input being discarded.

Carol Sutfin
AmSouth Bank NA
Corporate DBA




"Long, Ed" <[login to unmask email]> on 12/14/99 01:35:23 PM


Please respond to DB2 Data Base Discussion List <[login to unmask email]>

To: [login to unmask email]
cc: (bcc: Carol Sutfin/BIRMINGHAM/AL/AMSOUTH BANK)
Subject: When is Fast Load Neither?




Hi all. I was wondering whether anyone else has had a problem with
Ca/Platinum Fast Load similar to the following.

We have 2 DB2 systems on the same image, lets call them X and J.
X is non-Datasharing, J is in a 2way datasharing relationship. Both
systems
are DB2 V5.1, quite up to date maintenance wise.

A Fast load job for a table with a single clustering index works fine on X
but fails on J. There is nothing special about the table, no RI for
example.
The utility discards all records in the input dataset. Everything is the
same, input dataset, same JCL except for DB2 subsystem stuff, ie DSNLOAD.
The DISCARDS parameter is set to 0.

We used RC/MIGRATE to build the J tables from X. The IBM load has no
trouble
loading the data into J, it just takes a while.

We have opened a ticket with Ca/P but we are now 24hours into the adventure
and there has been no response. Obviously, their level 1 guy didn't see
anything in his database of a similar nature.

As a work around, I have converted all 300 jobs to use IBM load for now.

Any suggestions, or similar events.

Thanks for your suggestions.








Ed Long

Re: When is Fast Load Neither?
(in response to csutfin@AMSOUTH.COM)
Hi All.

After several adventures we found the problem.

The DISCARDS were because of a DATE field, essentially the input dataset and
column disagreed; but this is actually a clever Platinum error message that
the subsystem your running on is not defined in the SETUP member of the
Platinum parmlib. Neat message.

The DataSharing system involved has 2 members, DB2J and DJ02. DJ02 did not
have its own entry in the SETUP member. A suggestion has been opened to
Platinum development to create a more meaningful message earlier in the
process, like at utility startup perhaps. Now that DJ02 has its own entry,
the LOAD runs fine.

Thanks to Carol for her suggestions.



> -----Original Message-----
> From: [login to unmask email] [SMTP:[login to unmask email]
> Sent: Tuesday, December 14, 1999 4:04 PM
> To: [login to unmask email]
> Subject: Re: When is Fast Load Neither?
>
> Ed,
> Is FASTLOAD using the OBID of the object it's loading into? Was the data
> unloaded using FAST UNLOAD and with the load control parameter set to
> FASTLOAD?
>
> This would account for the entire input being discarded.
>
> Carol Sutfin
> AmSouth Bank NA
> Corporate DBA
>
>
>
>
> "Long, Ed" <[login to unmask email]> on 12/14/99 01:35:23 PM
>
>
> Please respond to DB2 Data Base Discussion List <[login to unmask email]>
>
> To: [login to unmask email]
> cc: (bcc: Carol Sutfin/BIRMINGHAM/AL/AMSOUTH BANK)
> Subject: When is Fast Load Neither?
>
>
>
>
> Hi all. I was wondering whether anyone else has had a problem with
> Ca/Platinum Fast Load similar to the following.
>
> We have 2 DB2 systems on the same image, lets call them X and J.
> X is non-Datasharing, J is in a 2way datasharing relationship. Both
> systems
> are DB2 V5.1, quite up to date maintenance wise.
>
> A Fast load job for a table with a single clustering index works fine on X
> but fails on J. There is nothing special about the table, no RI for
> example.
> The utility discards all records in the input dataset. Everything is the
> same, input dataset, same JCL except for DB2 subsystem stuff, ie DSNLOAD.
> The DISCARDS parameter is set to 0.
>
> We used RC/MIGRATE to build the J tables from X. The IBM load has no
> trouble
> loading the data into J, it just takes a while.
>
> We have opened a ticket with Ca/P but we are now 24hours into the
> adventure
> and there has been no response. Obviously, their level 1 guy didn't see
> anything in his database of a similar nature.
>
> As a work around, I have converted all 300 jobs to use IBM load for now.
>
> Any suggestions, or similar events.
>
> Thanks for your suggestions.
>
>
>
>
>
>
>
>
>
>