Possible FAQ: db2prep on NFS disk in Linux


Possible FAQ: db2prep on NFS disk in Linux
I imagine that this must be something others have seen before and
solved; but I can't find anything on the internet, or rather I get all
sorts of irrelevant references.

This is what happens: I build an application on a number of platforms -
SunOS, HP-UX, AIX, Linux mainly - and it involves running db2prep etc
for some of the modules. For practical reasons the source code is on an
NFS mounted disk shared between all the systems and is compiled on each
machine. This works fine everywhere, except on Linux, where it fails
with a message about 'File could not be opened'. When I run it through
strace, I can see that what actually seems to fail is an attempt to lock
the file with fcntl64().

Any suggestions?

Welcome to the IDUG DB2-L list. To unsubscribe, go to the archives and home page at http://www.idugdb2-l.org/archives/db2-l.html. From that page select "Join or Leave the list". The IDUG DB2-L FAQ is at http://www.idugdb2-l.org. The IDUG List Admins can be reached at [login to unmask email] Find out the latest on IDUG conferences at http://conferences.idug.org/index.cfm