Issue with installing DB2 Connect v11 on Windows 10 desktop

Jim Waid

Issue with installing DB2 Connect v11 on Windows 10 desktop

Has anyone had an issue installing DB2 connect v11.1 on a Windows 10 desktop and did you figure out how to make it successful?  Here is an issue we are seeing:

Part of the DB2 Client installation asks where you want to install the app it also asks what you want to name your DB2 copy. Previously, with 10.5, I had decided that the path would be C:\Program Files\IBM\DB2DSClient and the DB2 copy name would be DB2DSC. With version 11 I made a slight change to the install path to C:\Program Files\IBM\DB2DSClient11 while leaving the Db2 copy name the same. IBM’s default install path is C:\Program Files\IBM\SQLLIB and the default copy name is DB2COPY1.

 

I started to think that maybe there was an issue with me changing the defaults, so on my Windows 10 test VM I ran the setup.exe and took all the defaults. I just wanted it to be a generic install of DB2 so I could test the response file uninstall. I then rebooted the machine and copied the uninstall response file to C:\Program Files\IBM\SQLLIB\install. Finally, I ran the command "C:\Program Files\IBM\SQLLIB\BIN\db2unins" -u "C:\Program Files\IBM\SQLLIB\install\DB2DSC_11_1_FP2_Uninstall.rsp" -y -l %windir%\Key_Logs\DB2DSC_11.1_FP2_Uninstall.log.

I get the same error as I reported earlier (The DB2 copy is damaged or does not exist).

I then tried to run the following command "C:\Program Files\IBM\SQLLIB\BIN\db2unins" -p CLIENT and received the same error.